CherryCreek not performing as expected

Incident Report for UNLV

Resolved

This incident has been resolved.
Posted May 22, 2026 - 09:27 PDT

Monitoring

CherryCreek is currently functional for data retrieval. Active users should reach out to IT Support to inquire about their continued access to the platform.
Posted May 07, 2026 - 10:11 PDT

Identified

CherryCreek is currently experiencing intermittent issues. We are currently working to return Cherry Creek to a normal state as soon as possible.

--
UNLV Information Technology
IT Help Desk
ithelp@unlv.edu
702-895-0777
Posted Apr 24, 2026 - 13:42 PDT
This incident affected: Computing Services.